summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorKitty-Cricket Piapiac <kitty@piapiac.org>2023-11-13 05:39:45 +0000
committerKitty-Cricket Piapiac <kitty@piapiac.org>2023-11-13 05:39:45 +0000
commitb43906514a78b8491ef3c25f828e23a64edc526e (patch)
treea158985fd88634ab4fad411a07ceae78e3d80be4 /flake.nix
init
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..162247d
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,27 @@
+{
+ inputs = {
+ nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
+ flake-utils.url = "github:numtide/flake-utils";
+ zig.url = "github:mitchellh/zig-overlay";
+ };
+ outputs = { self, nixpkgs, flake-utils, zig }:
+ flake-utils.lib.eachDefaultSystem (system:
+ let
+ pkgs = import nixpkgs {
+ inherit system;
+ overlays = [
+ zig.overlays.default
+ ];
+ };
+ in {
+ devShells.default = pkgs.mkShell {
+ buildInputs = [
+ pkgs.SDL2
+ pkgs.SDL2.dev
+ pkgs.pkg-config
+ pkgs.zigpkgs.master
+ ];
+ };
+ }
+ );
+}